Modding:Updating mods for SMAPI 2.0

From Stardew Valley Wiki
Jump to: navigation, search

Index

For players with SMAPI 1.15: all the updates below are compatible with SMAPI 1.15.
For players with SMAPI 2.0: SMAPI 2.0 enables new kinds of mods, but no longer supports deprecated APIs. Mods with deprecation warnings won't work in SMAPI 2.0, which will release in Q4 2017. Those mods will work fine until then.

For players

What to do

  1. For each mod you have installed, follow the instructions in the list below. If it's not listed, try updating to its latest version.
  2. If a mod is still failing, post a message in the SMAPI 2.0 migration thread (with your SMAPI log attached) and we'll help.

SMAPI mods

Here's a list of mods tested with SMAPI 2.0. Please don't edit this list directly; post a message in the SMAPI 2.0 migration thread instead.

  1. This only shows whether a mod is compatible; it may have bugs unrelated to SMAPI 2.0. Many mods broke in Stardew Valley 1.1 and 1.2, so 'broken' doesn't necessarily mean broken by SMAPI 2.0 itself.

For mod developers

What to do

See how to update deprecated code. You can...

  • Add or update your mods in the list above (see format).
  • Post a message in the SMAPI 2.0 migration thread to ask questions or say when your mods are updated.
  • Chat or ask questions in #modding on Discord. (A preview version of SMAPI 2.0 is also pinned there to test your mods.)

When updating a mod, avoiding new SMAPI 2.0 APIs is strongly recommended. The new APIs are subject to change until 2.0 is officially released, and having mods only work in an unreleased version of SMAPI may confuse players. Instead, you should just fix deprecation warnings so your mods will work fine in both SMAPI 1.15 and 2.0.

Overall compatibility

Status of known SMAPI mods:

 
82% are compatible or have a working alternative.
 
7% have an update coming soon.
 
12% are broken and not open-source.¹

¹ Many of these broke in Stardew Valley 1.1 or 1.2. Some may be updated by their authors.